注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Study Desk

Share my desk with you!......

 
 
 

日志

 
 

用JDK5.0如何编译出在JDK1.4可以运行的程序  

2006-11-09 19:17:21|  分类: 爪哇岛 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
如果您安装的是JDK5.0,编译出来的class文件默认是无法在1.4上或更早版本的JRE上运行的,在不使用5.0的新功能的情况下,如果希望编译出的class可以在1.4或之前更早的环境上运行,则编译时必须指定-source与-target参数。-source指定原代码中可以使用的版本功能, -target指定编译出来的字节码适用的虚拟机器版本。例如要想编译出来的文件在1.4版本环境上运行运行,可以如下编译程序: javac -source 1.4 -target 1.4 ClassName.java
  评论这张
 
阅读(280)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017