注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Study Desk

Share my desk with you!......

 
 
 

日志

 
 

在 Ubuntu 9.04 上运行 Eclipse 3.4.2  

2009-08-03 21:38:59|  分类: 计总会 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
我自己总觉得不满意的是, Ubuntu 9.04 上的 Eclipse 还是 3.2 版。可现在 Eclipse 3.5 都发布 M2 了呢。

所以自己试着手动安装 Eclipse 3.4, 居然能正常运行。

从以下网址下载软件包:

eclipse classic 3.4.2
http://www.eclipse.org/downloads/
http://www.eclipse.org/downloads/downlo ... gtk.tar.gz
http://www.eclipse.org/downloads/downlo ... _64.tar.gz

eclipse language packs
http://download.eclipse.org/technology/ ... age_packs/
http://www.eclipse.org/downloads/downlo ... 085802.zip
http://www.eclipse.org/downloads/downlo ... 085802.zip

eclipse pydev
http://sourceforge.net/projects/pydev

eclipse cdt
http://download.eclipse.org/tools/cdt/r ... /ganymede/

下载好了,都放在桌面上,
双击打开 cdt-master-5.0.2.zip, 把里面的 plugins、features 文件夹留下,别的都删了。因为别的文件和中文语言包冲突。

再打开终端,执行
代码:
cd /opt/
sudo rm eclipse -rf
sudo tar xzf ~/Desktop/eclipse-SDK-3.4.2-linux-gtk-x86_64.tar.gz
sudo unzip -qo ~/Desktop/BabelLanguagePack-eclipse-zh_3.4.0.v20090423085802.zip
sudo unzip -qo ~/Desktop/BabelLanguagePack-tools.cdt-zh_3.4.0.v20090423085802.zip
sudo unzip -qo ~/Desktop/org.python.pydev.feature-1.4.5.2727.zip -d eclipse
sudo unzip -qo ~/Desktop/cdt-master-5.0.2.zip -d eclipse
sudo chmod -R a+r eclipse


再 sudo gedit /usr/share/applications/eclipse.desktop
文件内容为
代码:
[Desktop Entry]
Name=Eclipse
Exec=/opt/eclipse/eclipse -vmargs -Xms512M -Xmx1024M -Dsun.java2d.opengl=true
Terminal=false
Type=Application
StartupNotify=true
Icon=/opt/eclipse/plugins/org.eclipse.sdk_3.4.2.v200902111700/eclipse48.png
Categories=Development;


好啦,可以运行了 :em01

有兴趣的朋友还可以自己试试装 Eclipse 3.5 M2
  评论这张
 
阅读(2088)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017